Unidad 6. Las funciones (II)


6.3. Insertar función

Videotutorial Flash Videotutorial YouTube

Para insertar cualquier otra función, también podemos utilizar el asistente. Si queremos introducir una función en una celda:

Situarse en la celda donde queremos introducir la función.

Hacer clic en la pestaña Fórmulas

Elegir la opción Insertar función.

Insertar función

O bien, hacer clic sobre el botón boton formulas de la barra de fórmulas.

Aparecerá el siguiente cuadro de diálogo Insertar función:

insertar funcion

Excel 2010 nos permite buscar la función que necesitamos escribiendo una breve descripción de la función necesitada en el recuadro Buscar una función: y a continuación hacer clic sobre el botón boton ir, de esta forma no es necesario conocer cada una de las funciones que incorpora Excel ya que el nos mostrará en el cuadro de lista Seleccionar una función: las funciones que tienen que ver con la descripción escrita. 

Para que la lista de funciones no sea tan extensa podemos seleccionar previamente una categoría del cuadro combinado O seleccionar una categoría:, esto hará que en el cuadro de lista sólo aparezcan las funciones de la categoría elegida y reduzca por lo tanto la lista. Si no estamos muy seguros de la categoría podemos elegir Todas.

En el cuadro de lista Seleccionar una función: hay que elegir la función que deseamos haciendo clic sobre ésta.

Observa como conforme seleccionamos una función, en la parte inferior nos aparecen los distintos argumentos y una breve descripción de ésta. También disponemos de un enlace Ayuda sobre esta función para obtener una descripción más completa de dicha función.

A final, hacer clic sobre el botón Aceptar.

La ventana cambiará al cuadro de diálogo Argumentos de función, donde nos pide introducir los argumentos de la función: Este cuadro variará según la función que hayamos elegido, en nuestro caso se eligió la función SUMA ().

argumentos de funcion

En el recuadro Número1 hay que indicar el primer argumento que generalmente será una celda o rango de celdas tipo A1:B4 . Para ello, hacer clic sobre le botón para que el cuadro se haga más pequeño y podamos ver toda la hoja de cálculo, a continuación seleccionar el rango de celdas o la celda deseadas como primer argumento (para seleccionar un rango de celdas haz clic con el botón izquierdo del ratón sobre la primera celda del rango y sin soltar el botón arrástralo hasta la última celda del rango) y pulsar la tecla INTRO para volver al cuadro de diálogo.

En el recuadro Número2 habrá que indicar cuál será el segundo argumento. Sólo en caso de que existiera.

Si introducimos segundo argumento, aparecerá otro recuadro para el tercero, y así sucesivamente.

Cuando tengamos introducidos todos los argumentos, hacer clic sobre el botón Aceptar.

Si por algún motivo insertáramos una fila en medio del rango de una función, Excel expande automáticamente el rango incluyendo así el valor de la celda en el rango. Por ejemplo: Si tenemos en la celda A5 la función =SUMA(A1:A4) e insertamos un fila en la posición 3 la fórmula se expandirá automáticamente cambiando a =SUMA(A1:A5).

Si quieres conocer más sobre las referencias y nombres visita nuestro básico .

Utilizar Expresiones como argumentos de las Funciones

Excel permite que en una función tengamos como argumentos expresiones, por ejemplo la suma de dos celdas (A1+A3). El orden de ejecución de la función será primero resolver las expresiones y después ejecutar la función sobre el resultado de las expresiones.

Por ejemplo, si tenemos la siguiente función =Suma((A1+A3);(A2-A4)) donde:

A1 vale 1

A2 vale 5

A3 vale 2

A4 vale 3

Excel resolverá primero las expresiones (A1+A3) y (A2-A4) por lo que obtendremos los valores 3 y 2 respectivamente, después realizará la suma obteniendo así 5 como resultado.

Utilizar Funciones como argumentos de las Funciones

Excel también permite que una función se convierta en argumento de otra función, de esta forma podemos realizar operaciones realmente complejas en una simple celda. Por ejemplo =MAX(SUMA(A1:A4);B3) , esta fórmula consta de la combinación de dos funciones, la suma y el valor máximo. Excel realizará primero la suma SUMA(A1:A4) y después calculará el valor máximo entre el resultado de la suma y la celda B3.



Septiembre-2010
Pág. 6.2

Atrás  Inicio  Adelante






Curso de Excel 2013
.