Página inicial  

trans_770 trans_160

Unidad 14. Funciones (I)

Google

Esta unidad es una de las más importantes del curso en lo referente a OpenOffice.org Calc, pues en su comprensión y manejo está la base de OpenOffice.org Calc. Qué es una hoja de cálculo sino una base de datos que utilizamos con una serie de fórmulas para evitarnos tener que recalcular por cada cambio que hacemos. Por eso esta unidad es fundamental para el desarrollo del curso y la buena utilización de OpenOffice.org Calc.

Vamos a profundizar en el manejo de funciones ya definidas por OpenOffice.org Calc para agilizar la creación de hojas de cálculo, estudiando la sintaxis de éstas así como el uso del asistente para funciones, herramienta muy útil cuando no conocemos muy bien las funciones existentes o la sintaxis de éstas.

 

Introducir Funciones

Una función es una fórmula predefinida por OpenOffice.org Calc (o por el usuario) que opera con uno o más valores y devuelve un resultado que aparecerá directamente en la celda o será utilizado para calcular la fórmula que la contiene.

La sintaxis de cualquier función es:

nombre_función(argumento1;argumento2;...;argumentoN)

Siguen las siguientes reglas:

- Si la función va al comienzo de una fórmula debe empezar por el signo =.

- Los argumentos o valores de entrada van siempre entre paréntesis. No dejes espacios antes o después de cada paréntesis.

- Los argumentos pueden ser valores constantes (número o texto), fórmulas o funciones.

- Los argumentos deben de separarse por un punto y coma ;.

Ejemplo: =SUMA(A1:C8)

Tenemos la función SUMA() que devuelve como resultado la suma de sus argumentos. El operador ":" nos identifica un rango de celdas, así A1:C8 indica todas las celdas incluidas entre la celda A1 y la C8, así la función anterior sería equivalente a:

=A1+A2+A3+A4+A5+A6+A7+A8+B1+B2+B3+B4+B5+B6+B7+B8+C1+C2+C3+C4+C5+C6+C7+C8

En este ejemplo se puede apreciar la ventaja de utilizar la función.

Las fórmulas pueden contener más de una función, y pueden aparecer funciones anidadas dentro de la fórmula.

Ejemplo: =SUMA(A1:B4)/SUMA(C1:D4)

Existen muchos tipos de funciones dependiendo del tipo de operación o cálculo que realizan. Así hay funciones matemáticas y trigonométricas, estadísticas, financieras, de texto, de fecha y hora, lógicas, de base de datos, de búsqueda y referencia y de información.

Para introducir una fórmula debe escribirse en una celda cualquiera tal cual introducimos cualquier texto, precedida siempre del signo =.

Insertar función con el asistente

 

Una función como cualquier dato se puede escribir directamente en la celda si conocemos su sintaxis, pero OpenOffice.org Calc dispone de una ayuda o asistente para utilizarlas, así nos resultará más fácil trabajar con ellas.

Si queremos introducir una función en una celda:

Situarse en la celda donde queremos introducir la función, desplegar el menú Insertar.

Elegir la opción Función...

O bien, hacer clic sobre el botón boton formulas de la barra de fórmulas.

Aparecerá el cuadro de diálogo Insertar función de la imagen.

 

insertar funcion

OpenOffice.org Calc nos permite utilizar diversas funciones, éstas están clasificadas por categorías.

En el cuadro de lista Función tenemos la lista de funciones predefinidas, hay que elegir la función que deseamos haciendo clic sobre ésta.

Para que la lista de funciones no sea tan extensa podemos seleccionar previamente una categoría del cuadro combinado Categoría, esto hará que en el cuadro de lista sólo aparezcan las funciones de la categoría elegida y reduzca por lo tanto la lista. Si no estamos muy seguros de la categoría podemos elegir Todas.

Conforme seleccionamos una función, a la derecha aparecen los distintos argumentos y una breve descripción de ésta.

En el recuadro inferior Fórmula vemos la fórmula que vamos componiendo con ayuda del piloto y el resultado devuelto.

 

Pág. 14.1

Aviso legal: este curso es gratuito siempre que se visualice desde la página web de aulaClic. No está permitido descargar el curso ni utilizarlo sin estar conectado a Internet.
© aulaClic. Todos los derechos reservados. Free Computer tutorials. Prohibida la reproducción total o parcial por cualquier medio.
Julio-2005 www.aulaclic.es