Funciones que buscan un valor (II)


Función DESREF(ref;nfilas;ncolumnas;alto;ancho)

Devuelve una referencia de celdas situadas a partir de una referencia (ref) unas filas más abajo (nfilas positivo) o más arriba (nfilas negativo) y una columnas más a la derecha (ncolumnas positivo) o más a la izquierda (ncolumnas negativo). Los parámetros alto y ancho indican el número de celdas que se tienen que recuperar a partir del ahí.

Ejemplo: =DESREF(A1;2;3) devuelve el valor situado 2 filas más abajo y 3 columnas a la derecha de la celda A, es decir en la celda D3.

=SUMA(DESREF(K4;-3;-1;3;2)) obtiene la suma de las celdas devueltas por la función DESREF. En este caso la función desref devuelve las celdas J1:K3 para verlo veamos cómo interpretar la función: a partir de la celda K4 nos desplazamos 3 filas hacia arriba (nfilas -3) y 1 columna hacia la izquierda (ncolumnas -1) llegamos a la celda J1, a partir de esa celda cogemos 3 filas (alto 3) y 2 columnas (ancho 2), es decir las celdas J1,J2,J3,K1,K2 y K3, la función desref nos ha devuelto el rango J1:K3.

 

Función DIRECCION(fila;columna;abs;a1;hoja)

Crea una referencia de celda en forma de texto una vez especificada la fila y la columna.

abs = especifica el tipo de referencia que devuelve.

( 1 u omitido devuelve una referencia absoluta

2 devuelve una referencia fila absoluta, columna relativa

3 devuelve una referencia fila relativa, columna absoluta

4 devuelve una referencia relativa )

a1 = es un valor lógico que especifica el estilo de la referencia A1 o F1C1. Si a1 es VERDADERO o se omite, DIRECCION devuelve una referencia del estilo B3; si es FALSO, DIRECCION devuelve una referencia del estilo F3C2 (Fila3Columna2).

Hoja = es texto que especifica el nombre de la hoja de cálculo o que se utilizará como referencia externa. Si se omite hoja, no se utilizará ningún nombre de hoja.

 

Ejemplo: =DIRECCION(1;2) devuelve una referencia absoluta a ($B$1)

=DIRECCION(1;2;4) devuelve una referencia absoluta a (B1)

=DIRECCION(1;2;4;falso) devuelve una referencia absoluta a (F1C2)

Función ELEGIR(num_indice;valor1;valor2;...)

Elige un valor o una acción de una lista de valores a partir de un número de índice.

Ejemplo: =ELEGIR(3;"uva";"pera";"melón";"manzana") devuelve "melón" que está en la 3ª posición.

 

Función FILA(ref)

Devuelve el número de fila de una referencia.

Ejemplo: =FILA(A2:B5) devuelve 2, pues la celda A2 está en la fila 2.

 

Función FILAS(matriz)

Devuelve el número de filas que contiene una matriz.

Ejemplo: =FILAS(A2:B5) devuelve 4.

 

Función HIPERVÍNCULO(ubicación_del_vínculo;nombre_descriptivo)

Crea un acceso directo a un documento guardado en el disco duro o en Internet.

Ejemplo: =HIPERvínculo("HTTP://www.aulaclic.es";"AulaClic") crea un enlace a nuestra página Web.

 

Función IMPORTARDATOSDINAMICOS( camp_datos;tablas_dinámicas;campo1;elemento1;campo2;elemento2...)

Extrae datos almacenados en una tabla dinámica.

 

Función INDICE(matriz;num_fila;num_columna)

Dentro de un rango especificado por matriz, devuelve el valor de la celda que se encuentre en la intersección de una fila y una columna en particular.

Ejemplo: =INDICE(A3:B7;2;1) devuelve el valor de la celda que se encuentra en la segunda fila de la matriz y en la primera columna, es decir A4.

 

Función INDIRECTO(ref;a1)

Devuelve una referencia especificada por un valor de texto.

Ejemplo: =INDIRECTO(A2) devuelve el valor del enlace de la celda A2 que a su vez es un enlace. Imaginemos que en la celda B5 tenemos el valor 7 y en la celda A2 hemos puesto B5, si escribimos la función =INDIRECTO(A2) nos devuelve el valor 7.

Función TRANSPONER(matriz)

Intercambia en una matriz las filas por las columnas.

Tenemos una fila con los valores 4 6 7 9, y al realizar esta función.

Ejemplo: =TRANSPONER($A$1:$D$1) obtenemos como resultado el valor 4 en una fila, el valor 6 en la siguiente fila de la misma columna, etc...

Nota   La fórmula del ejemplo debe introducirse como fórmula matricial. Primero debemos seleccionar el rango A2:A5 comenzando por la celda de la fórmula, presionar F2 y, a continuación, CTRL+SHIFT+ENTRAR. Si la fórmula no se introduce como fórmula matricial, el resultado único es 1.


 

 

Enero - 2005.


Página inicial  Cursos Informática Gratuitos

Síguenos en:   Facebook       Sobre aulaClic            Política de Cookies


© aulaClic S.L. Todos los derechos reservados. Prohibida la reproducción por cualquier medio.