Unidad 4.  Fórmulas y Funciones (II)




Justo por debajo de la barra de fórmulas aparecerá el cuadro de diálogo Argumentos de función, donde nos pide introducir los argumentos de la función: Este cuadro variará según la función que hayamos elegido, en nuestro caso se eligió la función SUMA ().

argumentos de funcion

En el recuadro Número1 hay que indicar el primer argumento que generalmente será una celda o rango de celdas tipo A1:B4 . Para ello, hacer clic sobre le botón para que el cuadro se haga más pequeño y podamos ver toda la hoja de cálculo, a continuación seleccionar el rango de celdas o la celda deseadas como primer argumento (para seleccionar un rango de celdas haz clic con el botón izquierdo del ratón sobre la primera celda del rango y sin soltar el botón arrástralo hasta la última celda del rango) y pulsar la tecla INTRO para volver al cuadro de diálogo.

En el recuadro Número2 habrá que indicar cuál será el segundo argumento. Sólo en caso de que existiera.

Si introducimos segundo argumento, aparecerá otro recuadro para el tercero, y así sucesivamente.

Cuando tengamos introducidos todos los argumentos, hacer clic sobre el botón Aceptar.

Si por algún motivo insertáramos una fila en medio del rango de una función, Excel expande automáticamente el rango incluyendo así el valor de la celda en el rango. Por ejemplo: Si tenemos en la celda A5 la función =SUMA(A1:A4) e insertamos un fila en la posición 3 la fórmula se expandirá automáticamente cambiando a =SUMA(A1:A5) .

En la Barra de herramientas existe el botón Autosuma boton autosuma que nos permite realizar la función SUMA de forma más rápida.

Con este botón tenemos acceso también a otras funciones utilizando la flecha de la derecha del botón.

autosuma desplegadoAl hacer clic sobre ésta aparecerá la lista desplegable de la derecha:

 

Y podremos utilizar otra función que no sea la Suma, como puede ser Promedio (calcula la media aritmética), Cuenta (cuenta valores), Máx (obtiene el valor máximo) o Mín (obtiene el valor mínimo). Ademas de poder accesar al diálogo de funciones a través de Más Funciones...

 

Si quieres conocer más sobre las referencias y nombres visita nuestro básico .

Utilizar Expresiones como argumentos de las Funciones

Excel permite que en una función tengamos como argumentos expresiones, por ejemplo la suma de dos celdas (A1+A3). El orden de ejecución de la función será primero resolver las expresiones y después ejecutar la función sobre el resultado de las expresiones.

Por ejemplo, si tenemos la siguiente función =Suma((A1+A3);(A2-A4)) donde:

A1 vale 1

A2 vale 5

A3 vale 2

A4 vale 3

Excel resolverá primero las expresiones (A1+A3) y (A2-A4) por lo que obtendremos los valores 3 y 2 respectivamente, después realizará la suma obteniendo así 5 como resultado.

 

Utilizar Funciones como argumentos de las Funciones

Excel también permite que una función se convierta en argumento de otra función, de esta forma podemos realizar operaciones realmente complejas en una simple celda. Por ejemplo =MAX(SUMA(A1:A4);B3) , esta fórmula consta de la combinación de dos funciones, la suma y el valor máximo. Excel realizará primero la suma SUMA(A1:A4) y después calculará el valor máximo entre el resultado de la suma y la celda B3.

 


 

Pág. 4.2

Enero - 2005.


Página inicial  Cursos Informática Gratuitos

Síguenos en:   Facebook       Sobre aulaClic            Política de Cookies


© aulaClic S.L. Todos los derechos reservados. Prohibida la reproducción por cualquier medio.