Unidad 15. Trabajando con más funciones (XVII)

15.14. Sumar el total si todos son mayores que 0

SI tuviésemos un informe de los Gastos realizados en el periodo 2012 y 2013, de seguro que queremos obtener un total. Lamentablemente aún no se ha hecho la proyección de los Salarios del año 2013, entonces aún no se puede sumar, por ello vamos a utilizar una fórmula matricial para resolver este caso. Vea la siguiente tabla.

En la celda B8 vamos a utilizar la siguiente fórmula:

=SI(Y(B3:B7>0),SUMA(B3:B7)," ")

Pero si pulsas Enter, aparecerá un error de fórmula, y es porque estás utilizando resultados de rango en la fórmula, y solo las matrices pueden aceptarla, por ello, debes pulsar Ctrl + Mayus + Enter.

Es necesario utilizar Y para obligar a que se cumplan todas las condiciones del SI. Si no hubieras puesto él Y, la fórmula lo tomaría como la función O y esta es relativa. La siguiente fórmula en B16 devuelve una celda en blanco porque no se cumple al menos una condición.

=SI(Y(B11:B15>0),SUMA(B11:B15)," ")

Pág. 15.17

Atrás  Inicio  Adelante






Página inicial  Cursos Informática Gratuitos

Síguenos en:   Facebook       Sobre aulaClic            Política de Cookies