Unidad 4.  Funciones


Vamos a profundizar en el manejo de funciones ya definidas por Excel2002 para agilizar la creación de hojas de cálculo, estudiando la sintaxis de éstas así como el uso del asistente para funciones , herramienta muy útil cuando no conocemos muy bien las funciones existentes o la sintaxis de éstas.

 

Funciones

Una función es una fórmula predefinida por Excel2002 (o por el usuario) que opera con uno o más valores y devuelve un resultado que aparecerá directamente en la celda introducida.

La sintaxis de cualquier función es:

=nombre_función(argumento1;argumento2;...;argumentoN)

Siguen las siguientes reglas:

- Si la función va al comienzo de una fórmula debe empezar por el signo =.

- Los argumentos o valores de entrada van siempre entre paréntesis. No dejes espacios antes o después de cada paréntesis.

- Los argumentos pueden ser valores constantes (número o texto), fórmulas o funciones.

- Los argumentos deben de separarse por un punto y coma ;.

 

Ejemplos: =SUMA(A1:C8)

Tenemos la función SUMA() que devuelve como resultado la suma de sus argumentos. El operador ":" nos identifica un rango de celdas, así A1:C8 indica todas las celdas incluidas entre la celda A1 y la C8, así la función anterior sería equivalente a:

=A1+A2+A3+A4+A5+A6+A7+A8+B1+B2+B3+B4+B5+B6+B7+B8+C1+C2+C3+C4+C5+C6+C7+C8

En este ejemplo se puede apreciar la ventaja de utilizar la función.

Las fórmulas pueden contener más de una función, y pueden aparecer funciones anidadas dentro de la fórmula.

Ejemplo: =SUMA(A1:B4)/SUMA(C1:D4)

Existen muchos tipos de funciones dependiendo del tipo de operación o cálculo que realizan. Así hay funciones matemáticas y trigonométricas, estadísticas, financieras, de texto, de fecha y hora, lógicas, de base de datos, de búsqueda y referencia y de información.

Insertar función con el asistente

 

Una función como cualquier dato se puede escribir directamente en la celda, pero Excel2002 dispone de una ayuda o asistente para utilizarlas, así nos resultará más fácil trabajar con ellas.

Si queremos introducir una función en una celda:

Situarse en la celda donde queremos introducir la función, desplegar el menú Insertar.

Elegir la opción Función...

O bien, hacer clic sobre el botón de la barra de fórmulas.

Aparecerá el cuadro de diálogo de la derecha.

Excel 2002 incorpora como novedad el permitirnos buscar la función que necesitamos escribiendo una breve descripción de la función necesitada en el recuadro Buscar una función: y a continuación hacer clic sobre el botón , de esta forma no es necesario conocer cada una de las funciones que incorpora Excel ya que el nos mostrará en el cuadro de lista Seleccionar una funcion: las funciones que tienen que ver con la descripción escrita. 

 

En el cuadro de lista Seleccionar una función: hay que elegir la función que deseamos haciendo clic sobre ésta.

Para que la lista de funciones no sea tan extensa podemos seleccionar previamente una categoría del cuadro combinado O seleccionar una categoría:, esto hará que en el cuadro de lista sólo aparezcan las funciones de la categoría elegida y reduzca por lo tanto la lista. Si no estamos muy seguros de la categoría podemos elegir Todas.

Observa como conforme seleccionamos una función, en la parte inferior nos aparecen los distintos argumentos y una breve descripción de ésta. También hay un enlace Ayuda sobre esta función para obtener una descripción más completa de dicha función.

A final, hacer clic sobre el botón Aceptar.

Justo por debajo de la barra de fórmulas aparecerá el cuadro de diálogo Argumentos de función, donde nos pide introducir los argumentos de la función:. Este cuadro variará según la función que hayamos elegido, en nuestro caso se eligió la función SUMA ().

En el recuadro Número1 hay que indicar el primer argumento que generalmente será una celda o rango de celdas tipo A1:B4. Para ello, hacer clic sobre le botón para que el cuadro se haga más pequeño y podamos ver toda la hoja de cálculo, a continuación seleccionar el rango de celdas o la celda deseadas como primer argumento (para seleccionar un rango de celdas haz clic con el botón izquierdo del ratón sobre la primera celda del rango y sin soltar el botón arrástralo hasta la última celda del rango) y pulsar la tecla INTRO para volver al cuadro de diálogo.

En el recuadro Número2 habrá que indicar cuál será el segundo argumento. Sólo en caso de que existiera.

Si introducimos segundo argumento, aparecerá otro recuadro para el tercero, y así sucesivamente.

Cuando tengamos introducidos todos los argumentos, hacer clic sobre el botón Aceptar.

Si por algún motivo insertáramos una fila en medio del rango de una función Excel expande automáticamente el rango incluyendo así el valor de la celda en el rango. Por ejemplo: Si tenemos en la celda A5 la función =SUMA(A1:A4) e insertamos un fila en la posición 3 la fórmula se expandirá automáticamente cambiando a =SUMA(A1:A5).

En la Barra de herramientas existe el botón Autosuma que nos permite realizar la función SUMA de forma más rápida.

Como novedad, con este botón tenemos acceso también a otras funciones utilizando la flecha de la derecha del botón.

Al hacer clic sobre ésta aparecerá la lista desplegable de la derecha:

 

Y podremos utilizar otra función que no sea la SUMA, como puede ser PROMEDIO (calcula la media aritmética), CUENTA (cuenta valores), MAX (obtiene el valor máximo) o MIN (obtiene el valor mínimo).

 

Si quieres conocer más sobre las funciones visita nuestro avanzado .

Puedes practicar los distintos aspectos explicados en el tema en el Ejercicios sobre funciones.

 

  Ejercicios del Tema 4.

 

Prueba evaluativa teórica del Tema 4.

 

 

Pág. 4.1





Página inicial  Cursos Informática Gratuitos

Síguenos en:   Facebook       Sobre aulaClic            Política de Cookies


© aulaClic S.L. Todos los derechos reservados. Prohibida la reproducción por cualquier medio.